Différences

Ci-dessous, les différences entre deux révisions de la page.

Lien vers cette vue comparative

Les deux révisions précédentesRévision précédente
eclipse [Le 14/04/2026, 22:57] – mise en forme : sur le web, souligné = lien (inachevé) | màj lien fstab krodelabestioleeclipse [Le 16/09/2026, 15:36] (Version actuelle) – Mise en forme (https://forum.ubuntu-fr.org/viewtopic.php?pid=22907707#p22907707) nany
Ligne 137: Ligne 137:
  
   * Téléchargez directement (et en ignorant "Eclipse Installer") la version et la configuration qui vous convient sur la page [[https://www.eclipse.org/downloads/packages/|site officiel]], en effet des packs tout prêts suivant le langage de programmation que vous voudrez utiliser sont disponibles pour différentes plate-formes (x86, x86_64, PPC, ...), cherchez bien. Lisez la page comparative des différentes configurations [[https://www.eclipse.org/downloads/compare.php|Principales Configurations]] pour vous faire une idée.   * Téléchargez directement (et en ignorant "Eclipse Installer") la version et la configuration qui vous convient sur la page [[https://www.eclipse.org/downloads/packages/|site officiel]], en effet des packs tout prêts suivant le langage de programmation que vous voudrez utiliser sont disponibles pour différentes plate-formes (x86, x86_64, PPC, ...), cherchez bien. Lisez la page comparative des différentes configurations [[https://www.eclipse.org/downloads/compare.php|Principales Configurations]] pour vous faire une idée.
-  * Créez un dossier où vous voulez : **/opt/eclipse** ou pourquoi pas le dossier **.eclipse3.x** placé dans votre dossier personnel histoire qu'il "disparaisse" (__/!\__ //__attention__, évitez de nommer le dossier __.eclipse__ car il est utilisé par la version disponible dans les dépôts si vous comptez également utiliser cette dernière.//)+  * Créez un dossier où vous voulez : **/opt/eclipse** ou pourquoi pas le dossier **.eclipse3.x** placé dans votre dossier personnel histoire qu'il "disparaisse" (//__attention__, évitez de nommer le dossier __.eclipse__ car il est utilisé par la version disponible dans les dépôts si vous comptez également utiliser cette dernière.//)
   * Décompressez l'archive précédemment téléchargée dans ce dossier (une remarque, les archives contiennent le dossier "eclipse" qui au final ne sert à rien si on choisit un autre nom pour le dossier où nous plaçons les fichiers)   * Décompressez l'archive précédemment téléchargée dans ce dossier (une remarque, les archives contiennent le dossier "eclipse" qui au final ne sert à rien si on choisit un autre nom pour le dossier où nous plaçons les fichiers)
   * Lancer Eclipse en le situant bien dans son répertoire d'installation : /opt/eclipse/eclipse ou ~/.eclipse3.X/eclipse. Attention, tant que votre eclipse n'est pas dans le $PATH, la commande "eclipse" vous invitera à installer le dépôt ou, si celui-ci est installé, lancera la version eclipse du dépôt.   * Lancer Eclipse en le situant bien dans son répertoire d'installation : /opt/eclipse/eclipse ou ~/.eclipse3.X/eclipse. Attention, tant que votre eclipse n'est pas dans le $PATH, la commande "eclipse" vous invitera à installer le dépôt ou, si celui-ci est installé, lancera la version eclipse du dépôt.
Ligne 340: Ligne 340:
  
 ===== Principales Configurations ===== ===== Principales Configurations =====
-Vous pouvez configurer **Eclipse** ainsi que toutes ses extensions au même endroit en allant dans le menu //**Fenêtre > Préférences...**  (window > Préférences... en anglais)// qui se présente avec à gauche les différents éléments configurables (Général, Java, Ant, ...) sous forme d'une arborescence, et à droite les différentes options de configuration suivant l'élément sélectionné. Tous les greffons que vous installerez rajouteront leur page de configuration à cet endroit pour que vous puissiez y accéder facilement.+Vous pouvez configurer **Eclipse** ainsi que toutes ses extensions au même endroit en allant dans le menu //**Fenêtre > Préférences...**  (window > Preferences... en anglais)// qui se présente avec à gauche les différents éléments configurables (Général, Java, Ant, ...) sous forme d'une arborescence, et à droite les différentes options de configuration suivant l'élément sélectionné. Tous les greffons que vous installerez rajouteront leur page de configuration à cet endroit pour que vous puissiez y accéder facilement.
  
 ==== Eclipse pour Java ==== ==== Eclipse pour Java ====
Ligne 453: Ligne 453:
   * Relancer Eclipse.   * Relancer Eclipse.
  
-Aller ensuite dans les préférences pour configurer selon vos besoins **Window -> Preferences -> Ruby -> Interpreters **+Aller ensuite dans les préférences pour configurer selon vos besoins **Window -> Preferences -> Ruby -> Interpreters**
  
 === Ruby/Ruby on Rails par Aptana === === Ruby/Ruby on Rails par Aptana ===
Ligne 461: Ligne 461:
   * Dans le menu **Help -> Install new Software**   * Dans le menu **Help -> Install new Software**
   * Ajouter un **Nouveau Site Distant...** (New Remote Site)  <file> http://download.aptana.com/studio3/plugin/install</file>   * Ajouter un **Nouveau Site Distant...** (New Remote Site)  <file> http://download.aptana.com/studio3/plugin/install</file>
-  * Sélectionnez ce site et installez : ** Aptana Studio ... Plugin**+  * Sélectionnez ce site et installez : **Aptana Studio ... Plugin**
   * Relancer Eclipse   * Relancer Eclipse
  
Ligne 483: Ligne 483:
   * Redémarrer Eclipse.   * Redémarrer Eclipse.
  
-Le meilleurs moyen pour faire connaissance avec ces nouveaux plugins est, sans aucun doute, d'ouvrir la liste des assistants qu'ils ont apportés dans le menu **File -> New -> Others ... ** ou la liste de nouvelles vues qu'ils offrent dans "Window -> show view -> Others ..."+Le meilleurs moyen pour faire connaissance avec ces nouveaux plugins est, sans aucun doute, d'ouvrir la liste des assistants qu'ils ont apportés dans le menu **File -> New -> Others ...** ou la liste de nouvelles vues qu'ils offrent dans "Window -> show view -> Others ..."
  
 === Web 2.0 avec AJAX === === Web 2.0 avec AJAX ===
Ligne 507: Ligne 507:
   * Dans le menu **Help -> Install new Software**   * Dans le menu **Help -> Install new Software**
   * Ajouter un **Nouveau Site Distant...** (New Remote Site)  <file> http://download.aptana.com/studio3/plugin/install</file>   * Ajouter un **Nouveau Site Distant...** (New Remote Site)  <file> http://download.aptana.com/studio3/plugin/install</file>
-  * Sélectionnez ce site et installez : ** Aptana Studio ... Plugin**+  * Sélectionnez ce site et installez : **Aptana Studio ... Plugin**
   * Relancer Eclipse   * Relancer Eclipse